flake.nix 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. {
  2. inputs = { nixpkgs.url = "github:nixos/nixpkgs"; };
  3. outputs = { self, nixpkgs }:
  4. let
  5. supportedSystems =
  6. let
  7. unsupportedSystems = [
  8. # GHC not supported
  9. "armv5tel-linux"
  10. "armv6l-linux"
  11. "powerpc64le-linux"
  12. "riscv64-linux"
  13. # "error: attribute 'busybox' missing" when building
  14. # `bootstrap-tools`
  15. "mipsel-linux"
  16. ];
  17. in nixpkgs.lib.subtractLists unsupportedSystems nixpkgs.lib.systems.flakeExposed;
  18. perSystem = nixpkgs.lib.genAttrs supportedSystems;
  19. pkgsFor = system: import nixpkgs { inherit system; };
  20. buildResumeFor = system:
  21. let pkgs = pkgsFor system;
  22. in pkgs.runCommand "build-resume" {
  23. nativeBuildInputs = with pkgs; [ pandoc texlive.combined.scheme-context ];
  24. } ''
  25. cd ${self}
  26. make OUT_DIR="$out"
  27. '';
  28. in {
  29. packages = perSystem (system: {
  30. resume = buildResumeFor system;
  31. });
  32. devShell =
  33. perSystem (system: import ./shell.nix { pkgs = pkgsFor system; });
  34. defaultPackage = perSystem (system: self.packages.${system}.resume);
  35. };
  36. }