flake.nix 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. {
  2. inputs = { nixpkgs.url = "github:nixos/nixpkgs"; };
  3. outputs = { self, nixpkgs }:
  4. let
  5. supportedSystems =
  6. let
  7. unsupportedSystems = [
  8. # GHC not supported
  9. "armv5tel-linux"
  10. "armv6l-linux"
  11. "powerpc64le-linux"
  12. "riscv64-linux"
  13. # "error: attribute 'busybox' missing" when building
  14. # `bootstrap-tools`
  15. "mipsel-linux"
  16. ];
  17. in nixpkgs.lib.subtractLists unsupportedSystems nixpkgs.lib.systems.flakeExposed;
  18. perSystem = nixpkgs.lib.genAttrs supportedSystems;
  19. pkgsFor = system: import nixpkgs { inherit system; };
  20. buildResumeFor = system:
  21. let pkgs = pkgsFor system;
  22. in pkgs.runCommand "build-resume" {
  23. nativeBuildInputs = with pkgs; [ pandoc texlive.combined.scheme-context ];
  24. } ''
  25. cd ${self}
  26. make OUT_DIR="$out"
  27. '';
  28. in {
  29. packages.resume = perSystem (system: buildResumeFor system);
  30. devShell =
  31. perSystem (system: import ./shell.nix { pkgs = pkgsFor system; });
  32. defaultPackage = perSystem (system: self.packages.resume.${system});
  33. };
  34. }